Gebruiker toevoegen en verwijderen

Als je de standaard gebruiker “pi” wilt verwijderen en je eigen gebruiker wilt toevoegen ga je als volgt te werk.

Maak verbinding met je Rpi d.m.v. SSH
type

groups

Je krijgt nu een lijst met groepen waar “pi” rechten voor heeft.
selecteer alle groepen(niet “pi” alleen de groepen).

mijn situatie ziet er als volgt uit

pi adm dialout cdrom sudo audio video plugdev games users netdev input indiecity spi gpio

Om er voor te zorgen dat de nieuwe gebruiker alle rechten over kan nemen gaan we de groepen nu toewijzen aan de nieuwe gebruiker.

sudo useradd -m -G adm,dialout,cdrom,sudo,audio,video,plugdev,games,users,netdev,input,indiecity,spi,gpio NIEUWEGEBRUIKER

Waar bij NIEUWEGEBRUIKER jou eigen gebruiker komt.

De “-m” optie zorgt ervoor dat er een home directory aangemaakt word.
De “-G” optie zorgt ervoor dat de nieuwe gebruiker de rechten krijgt over de opgegeven groups

Geef de nieuwe gebruiker een wachtwoord.

sudo passwd NIEUWEGEBRUIKER

volg de actie die gevraagd worden tijdens het proces.

herstart nu de Rpi

sudo reboot

log nu in met de nieuwe gebruiker.
Verwijder het standaard “pi” account.

sudo deluser –remove-all-files pi

Het duurt misschien eventjes maar hij zoekt alles bij elkaar wat met “pi” verbonden is.

Succes.

FacebookGoogle+TwitterDelen

Wachtwoord veranderen

Met het oog op veiligheid is het belangrijk als eerst het wachtwoord van je RaspberryPi(hierna Rpi) te veranderen.

Maak verbinding met je Rpi d.m.v. SSH
het standaard wachtwoord is “raspberry”

type:
sudo passwd pi

Je word nu gevraagd je wachtwoord op te geven.
dit is de eerste keer dat je jouw nieuwe wachtwoord invoert.(je ziet de cursur niet bewegen zoals in bijv. windows)

druk op ENTER

Herhaal jou wachtwoord nog een keer.
dit is de verificatie om te controleren dat je twee keer het zelfde wachtwoord opgeeft

Je nieuwe wachtwoord is klaar voor gebruik.
Log uit en maak opnieuw verbinding.

Succes.

POODLE kwetsbaarheid uitschakelen FireFox

SSLv3 a.k.a. POODLE kwetsbaarheid in FireFox

Om dat SSL v3 officieel is overleden op 15 oktober 2014 zijn protocollen met deze manier van encryptie niet veilig meer tegen de zo genoemde “man in the middel attack” Het is dus mogelijk om gegevens te onderscheppen en te decoderen.

Wees enig sinds gerust want banken hebben deze manier van encryptie in de meeste gevallen uitgeschakeld.

FIREFOX gaat in de loop van november (24 november) een update uitbrengen waar de ondersteuning van SSLv3 standaard uitgeschakeld is.

Als je niet kan wachten kan je zelf op 2 manieren doen.

Controleer eerst op de website van SSLLABS.com  of jou Browser kwetsbaar is voor #POODLE SSLv3



Voor de gene die niet bang zijn om ijskoud wat veranderingen door te voeren.

  1. Open je FireFox browser en type in het adres balk:
    about:config en klik op <ENTER>
    Je krijgt nu een melding te zien zoals hieronder.

firefox_melding
klik op “IK ZAL VOORZICHTIG ZIJN, dat beloof ik” 🙂

Je krijgt nu een hele lijst met configuraties.
Type in de zoekbalk het volgende:

security.tls.version.min

Je ziet nu helemaal boven de volgende regel:

POODLE_FIREFOX_FIX_SSLv3

Dubbel klik op de regel, er opent een venster waar de waarde “0” in staat, verander deze naar “1” en klik op OK.

POODLE_FIREFOX_FIX_SSLv3_OK

Sluit de browser en start hem opnieuw op.

Controleer of het gelukt is op de website van “SSLLABS.COM”  of de kwetsbaarheid inderdaad uitgeschakeld is.



Voor de gene die liever een “add-on” installeert voor firefox

2. Ga naar FirefoxADD-ON en installeer de add-on.

Inschakelen en klaar!

Controleer of de kwetsbaarheid daadwerkelijk uitgeschakeld is op
SSLLABS.com